Problems finding (and keeping) peers


#1

Hi, I downloaded the Windows 64bit RC2 wallet, allowed it to go through firewall but I’m not finding stable peers. I added the node IP’s posted in BCT, let the wallet run for 24hrs, but no luck downloading the blockchain.

When I look in the peer tab, I see peers come and go within a split second… I downloaded 199 blocks in 24hrs… clearly something is not working… any idea what that might be?


#2

Hi, try this command in the console (Help->Debug Window -> Console) to clear your ban list.

clearbanned

And than, the below commands will add known bitcoin stash nodes as your peer, try it out.

addnode 104.248.124.131 onetry
addnode 68.183.164.1 onetry
addnode 39.106.250.31 onetry
addnode 68.183.130.109 onetry

If that still doesn’t work let me know. It is possible that if you are running both Bitcoin Cash and Bitcoin Stash nodes from the same IP, the Bitcoin Cash node is getting you banned on the Bitcoin Stash network…


#3

I did as you suggested, still doesn’t work…

There was indeed an ABC wallet running on that same machine, but I deleted everything ABC and still no sync for Stash wallet…


#4

Note: I’m running the stash linux wallet without any problems from the same IP


#5

Ah, are you running your linux wallet at the same time as your window wallet? You cannot do that I believe.
Either change the port number on your windows wallet or linux wallet, for example

bitcoin-qt.exe -port=[some random port number]


#6

Only on one location do I run Windows and Linux (I’ll try shutting down the Linux wallet)

I also have a VPS with only Windows wallet, same issue,

I tried at home with only Windows wallet, same issue…


#7

Update: Linux wallet shut down, still same issue…


#8

Thanks for reporting this, I was able to reproduce this problem on a windows machine. Will have to take a closer look to see what’s wrong.


#9

The bug causing this was found, and the fix is now available in the repo https://github.com/bstash/BitcoinStash/

Binaries will be rolled out soon once the build finishes and we can confirm that there are no problems. Thanks!


#10

Great, I’ll check as soon as binaries are uploaded…


#11

windows binary up now: https://github.com/bstash/BitcoinStash/releases/tag/v0.0rc3


#12

problem solved, awesome!


#13

Awesome!

Thread moved to Help section. If you need tech assistance, please use our Help section. :wink: